Veloce oil/water emulsion

Discuss the new Corsaro and Avio 1200s

Re: Veloce oil/water emulsion

Postby fredlabulle » 16 Apr 2018 19:11

Ming wrote:I think Fred means that the right hand crankcase (carter) shows a screw hole on the design drawings which would improve the sealing. The joint has a hole in the appropriate position, but there is no screw. Does that help? Confused me a bit...


That s right , i try to post a photography
fb
fredlabulle
 
Posts: 5
Joined: 11 Apr 2018 16:47

Re: Veloce oil/water emulsion

Postby backfat1187 » 24 May 2018 22:16

I see what you mean. The hole (or lack of hole) appears to be in line with a screw holding the water pump cover on.

Leakdown test didn't indicate anything obvious. Leakage the same on both cylinders (about 30%). You can hear it getting past the rings.
So I reckon there are a few scenarios...

-Neither head gasket has gone and the leakage is just the piston rings.
-Both have gone and the leakage is rings and gaskets combined.
-One gasket has gone, the leakage of which combined with ring leakage matches the other cylinder ring only leakage.

The second two scenarios seem unlikely to me and given there was no pressurization of the cooling circuit and the bike started easily, I reckon the head gaskets are fine and the most likely culprit is the water pump shaft seal. Possibly as a result of shaft deviation. I shall replace the seal and see how we go.

Can't believe the bike has been sitting there on the lift while we've had all this fab weather!
backfat1187
 
Posts: 116
Joined: 13 Mar 2011 23:11
Location: Leicester, UK

Re: Veloce oil/water emulsion

Postby backfat1187 » 24 Aug 2018 17:49

So I've done a few hundred miles with the new shaft seal but have again found oil in the rad. It's a small amount and I can't see any creamy white emulsion in the oil. The amount of oil in the sump doesn't appear to be decreasing but I don't suppose it would be possible to notice a tiny amount of change just using the sight glass.
I think I'll flush the coolant circuit and renew the coolant again in case it's residual oil from the previous leak.
If it turns out that I still have a problem, other than the shaft seal and the head gaskets, any ideas on how/why/where the cross contamination is happening?
Thanks for any thoughts.
Jim.
backfat1187
 
Posts: 116
Joined: 13 Mar 2011 23:11
Location: Leicester, UK

Previous

Return to Corsaro and Avio 1200

Who is online

Users browsing this forum: No registered users and 2 guests