Need some thoughts over this one. Well Done NLM!

Discuss the new Corsaro and Avio 1200s

Need some thoughts over this one. Well Done NLM!

Postby Chips1953 » 10 Sep 2014 17:28

I have had problems with getting the Corsaro started and have left it all summer as I've been involved in other things. I wanted to take her on a run with a group of friends so......................
So I got the beast started by removing the front plug, badly sooted up and all appeared to be great.
The expansion tank started to drip coolant well below 90 degrees. As the fans are not supposed to come before this, I suspect the thermostat.
The problem is the main beam and the dipped beam don't operate. They do if I activate the relays manually. I have changed the relays, no go. The main beam noddy light comes on when the switch is thrown.
I have a feeling that it may be a wiring fault or there is something amiss with the general relay or it is not being called.
I will be going through the manual again tonight, but does any body have a wiring schedule?
There is a picture of the wiring loom in the manual but no schematic.
Last edited by Chips1953 on 17 Sep 2014 11:56, edited 1 time in total.
Singer 185K
Wheel Horse commando 7
Honda SS90 1965
User avatar
Chips1953
 
Posts: 406
Joined: 02 Dec 2011 14:05

Re: Need some thoughts over this one.

Postby franco82 » 10 Sep 2014 19:35

Send me PM with your email. I got wiring diagram from one kind member of this forum.
User avatar
franco82
 
Posts: 66
Joined: 27 Sep 2012 09:04

Re: Need some thoughts over this one.

Postby Chips1953 » 12 Sep 2014 16:16

Ok

I got the Schematic from Franco......
Many thanks for that.
The problem lies with the Dashboard. The signal to activate the relays comes through the Dashboard, this is the way the lights are extinguished after 30 seconds to save the battery when the motor is not running.
So it's about £500 for the new dash, according to NLM.
Oh I don't think so. A couple of wires will do the trick and sod the 30 seconds. I may change the switch gear and just do it the old way.
To be completely honest I won't be buying another new Morini.
This is the second dash that has gone awry on this bike. The previous owner had to change it as well.
Unless someone can come up with a novel idea.?
Singer 185K
Wheel Horse commando 7
Honda SS90 1965
User avatar
Chips1953
 
Posts: 406
Joined: 02 Dec 2011 14:05

Re: Need some thoughts over this one.

Postby butchamphib » 16 Sep 2014 09:44

Google Mae they have a very good repair service which has been discussed on this foram in the past.
butchamphib
 
Posts: 99
Joined: 26 May 2010 12:57

Re: Need some thoughts over this one.

Postby Chips1953 » 16 Sep 2014 16:18

I have sent off an Email to MAE. Thanks for that. I see that sometimes they are a problem. Anyway any chance is better than none.
I have Moto Mecca on the case as well as NLM.
butchamphib wrote:Google Mae they have a very good repair service which has been discussed on this foram in the past.


Many thanks for the help.

P.S. I got in touch with 3X they were very helpful but they have no more old spares for the Dash, even damaged ones.
Singer 185K
Wheel Horse commando 7
Honda SS90 1965
User avatar
Chips1953
 
Posts: 406
Joined: 02 Dec 2011 14:05

Re: Need some thoughts over this one.

Postby Chips1953 » 17 Sep 2014 11:37

Well I cannot believe it, but NLM have come up trumps.
The cost of a new dash is £400.02 plus VAT.
I had been looking at no OEM units, but most of them are non Can Bus. That is except for the really expensive ones.
Singer 185K
Wheel Horse commando 7
Honda SS90 1965
User avatar
Chips1953
 
Posts: 406
Joined: 02 Dec 2011 14:05

Re: Need some thoughts over this one. Well Done NLM!

Postby günni » 17 Sep 2014 12:51

Chips1953 wrote:The problem is the main beam and the dipped beam don't operate. They do if I activate the relays manually.


hi chips,
if the lights don`t work, you also could try to repair the dashboard by yourself. mostly the following transistors (shown on the foto) are the reason for "dark lights" 8)

Austausch_PC_847 MPM Transistor_2.jpg
Austausch_PC_847 MPM Transistor_2.jpg (190.71 KiB) Viewed 7348 times


Austausch_PC_847 MPM Transistor.jpg
Austausch_PC_847 MPM Transistor.jpg (196.64 KiB) Viewed 7348 times
sbarazzino 98, corsaro 125, corsaro 150, corsaro 1200, scrambler
günni
 
Posts: 40
Joined: 01 Mar 2013 23:30
Location: germany

Re: Need some thoughts over this one. Well Done NLM!

Postby Chips1953 » 17 Sep 2014 17:02

Hi Gunni


if the lights don`t work, you also could try to repair the dashboard by yourself. mostly the following transistors (shown on the foto) are the reason for "dark lights" 8)


Well that's cool. I have the capability but not the transistors. What are they, please.
Have you done this yourself? Perhaps you could setup a repair facility for the Corsaro etc.

Thanks
Singer 185K
Wheel Horse commando 7
Honda SS90 1965
User avatar
Chips1953
 
Posts: 406
Joined: 02 Dec 2011 14:05

Re: Need some thoughts over this one. Well Done NLM!

Postby Motociklet » 25 May 2018 10:23

Hello.
Have the same problem - there is no signal from dash to low/highbeam relays. We measured just +5v from dash, as I understand it should be -12v when the engine is starts. So headlights don't work, blue light on dash sometimes blinking when highbeam is switched on.
Checked wiring (light works when contacts on relays are closed manualy) - everything is ok, we tried a few relays - the problem remains.

Plus I found that such problem occurs frequently
viewtopic.php?f=2&t=2904#p14328
günni wrote:hi stauch,

i don`t understand, which light does not work? low and high beam? both? please use "english" for your translation from russian!
the headlight-relays are activated by the speedometer.
first aid, you could remove the relays and bridge with a cable the wide contacts in the relay-socket. don`t forget to switch on ignition!
when the headlights light up, you have to check the way from the speedometer. i know that problem from many corsaros.
there very often the speedometer is faulty.

here the corsaro relay-socket, only as an example

P1060717.JPG


A few questions:
1. What else should I checked? Maybe there is a known gremlin which is sometime?
2. Did anyone repair dash as Mr. günni wrote above (change transistors)? if yes, could you share your expirience?
3. If repair of dash is impossible or quite hard, what is the best way to connect headlights bypassing the dashboard. It is better to connect headlights in such way when it works only when engine works - to take care of wiring/battery.

Thank you in advance.
Oleg
Motociklet
 
Posts: 1
Joined: 12 Mar 2017 22:58


Return to Corsaro and Avio 1200

Who is online

Users browsing this forum: No registered users and 1 guest