Won't rev over 5K

Maestro, SEI-V

Won't rev over 5K

Postby carlosfandango » 26 Sep 2019 21:42

Hi there

i have a 1980 500S, at the moment it won't rev over 5K
I've tried everything - cleaned the carbs, done the timing, tappets set OK balanced the carbs. Fitted new O rings
Even fitted a new fuel tap.

so i know it is getting fuel in, just won't rev.

Next step is to purchase new choke parts as the seals seem to have an indentation in.

Any other thoughts? It feels like fuel starvation, do i look at the jetting?

Any help welcomed
carlosfandango
 
Posts: 2
Joined: 14 Oct 2018 20:21

Re: Won't rev over 5K

Postby mbmm350s » 26 Sep 2019 22:20

HI
If you checked all the fuel side and there is no blockage in exhaust or air filters then it's likely to be an ignition fault. Is it standard carbs air filter and exhaust?
If you can strobe time it then for a 500 then it timed at 5500 rpm so it can pull beyond 5000rpm
Obviously that is a lightly loaded engine. When the engine is loaded more voltage is required to create the spark so I would suspect a breakdown of a component of the ignition system.
First to check the plugs leads and earths particularly at the headstock and the engine earths. If these check out ok then it could be a transducer fault an ignition winding fault Weak or Demagnetised rotor, pick up unit fault
Do you have the workshop manual? It explains how to check the ignition system.
Mark
mbmm350s
 
Posts: 181
Joined: 22 Jun 2018 10:18
Location: Berkshire UK


Return to The 500

Who is online

Users browsing this forum: No registered users and 1 guest

cron